В 1с возврат каретки

Убрать из строки символы табуляции.

Уважаемые подскажите , что не так.

Вообщем получаю данные из таблицы Word-а. В обработку получаю строку таблицы и соответствующие ячейки пихаю куда надо. Но получилось что в ячейке при заполнении ручками ставят ентер ну и получается что моя строка получается много строчной :). Пытаюсь убрать все эти табуляции строчками кода

Как поставить символ переноса строки в 1С 8

Мне нужно сформировать многострочную строку, для этого необходимо осуществлять переход на новую строку, а я не знаю как. Подскажите как в 1С 8 поставить символ перехода на новую строку?

Для осуществления перехода на новую строку необходимо воспользоваться конструкцией встроенного языка 1С 8 Символы, которая содержит набор специальных символов. Переход на следующую строку делается при помощи символа ПС.

В конструкции Символы также содержаться:

  • ВК (CR) — возврат каретки;
  • ВТаб (VTab) — символ табуляции (вертикальной);
  • НПП (NBSp) — неразрывный пробел. Пробел, по которому не должен выполняться перенос на другую строку или другое разбиение текста при форматировании;
  • ПФ (FF) — перевод формы (страницы);
  • Таб (Tab) — символ табуляции (горизонтальной).

Символ переноса строки в 1С 7.7 для текстовой переменной

Здравствуйте. Народ, подскажите такой вопрос: есть строковая переменна «ПереченьОборуд» в нее в цикле набивается наименование оборудования и количество:

Смотрите так же:  Льготы для вновь созданных ооо в 2019

как сделать, что бы после каждого шага цикла перечень оборудования было с новой строки? есть ли спец символ перевода на новую строку. ну типо что-то CHR13.

(3) +100! Понавоспитывали русскоязычных кодеров на инапсулированых сущностях с неизвестным поведением, не описанным в документации.

6 — 28.01.11 — 14:41 (3) +100! Понавоспитывали русскоязычных кодеров на инапсулированых сущностях с неизвестным поведением, не описанным в документации.

да вот тож. было бы как обычно млин CHR13. нет же понавыдумывали.

ПереченьОборуд = ПереченьОборуд + СпрОборуд.Наименование + «: » + СпрОборуд.количество + «; »
«»;

Форум поддержки читателей книги «Практическое пособие разработчика. Примеры и типовые приемы»

В последних версиях 8.3 похоже проверку пустой строки реализовали примерно так:

Т.е. «Значение» не обязательно должно быть строкового типа.

Поэтому рекомендую вообще отказаться от использования функции ПустаяСтрока.

> 1. В чем разница применения этих двух функций

Кажется, что разница достаточно подробно написана в синтакс-помощнике:

ЗначениеЗаполнено() работает с типами: Булево, Строка, с массивами и коллекциями.

ПустаяСтрока() работает только со строками.

> Становится не совсем понятно: т.е. если строка не содержит значащие цифры, тогда возвращается Истина. Хотя в отладчике вводил в поле ввода пробел (незначаший символ), все равно результат Истина (также выдается предупреждение «Значение не заполнено»)
Непоянтно, что здесь непонятно.

Если нет значащих символов, тогда Истина. Вы вводите пробел. Он не является значащим символом. Получаете Истина. Все ровно так, как описано.

Форум поддержки читателей книги «Практическое пособие разработчика. Примеры и типовые приемы»

По всякому пытаюсь вставить символ перевода строки в выражение вычислимого поля в СКД, но ничего не выходит. Делать для этой цели отдельную процедуру в общем модуле и производить из СКД ее вызов не хочу. Неужели для этого нет другого решения? Пример кода, который пытаюсь создать:

Смотрите так же:  Президент компетенция и полномочия

ЗначениеЗаполнено(ВыданоСотрудник) И ЗначениеЗаполнено(ПолученоСотрудник) И (ВыданоСотрудник <> ПолученоСотрудник)
Тогда
ВыданоСотрудник + Символы.ПС + ПолученоСотрудник
Иначе
ВыданоСотрудник

Можно сделать так, как в примере приложения — через пользовательские поля.

Спасибо, получилось! 🙂 Вообще, мне почему-то такой вариант и в голову не приходил. Для интересующихся сообщаю, что надо действовать так:

ЗначениеЗаполнено(ВыданоСотрудник) И ЗначениеЗаполнено(ПолученоСотрудник) И (ВыданоСотрудник <> ПолученоСотрудник)
Тогда
ВыданоСотрудник + «
» + ПолученоСотрудник
Иначе
ВыданоСотрудник

новая строка в тексте сообщения в 1С

В ссылке приведены два способа.
Первый — с использованием символа |

Переменная = «Привет,
| мир! «;

Этот способ работает.
Второй – с использованием системного перечисления Символы.

Переменная = «Привет» + Символы.ПС + «мир! «;

А где взять Символы.ПС и как им поьзоваться?

С уважением, Лодя. 10 декабря 2012г.

Можно, способ 1:
Переменная = «Привет,
| мир! «;
способ 2:
Переменная = «Привет» + Символы.ПС + «мир! «; (ПС — значит перенос строки, точка — значит доступ к ПС или другой команде)
Например:
ПС — перевод строки (помещение курсора на следующую строку),
ВК — возврат каретки (помещение курсора в начало строки),
Таб — символ табуляции,
ПФ — перевод формы (страницы),
ВТаб — вертикальная табуляция,
НПП — неразрывный пробел.
Отвечая прямо на Ваш вопрос. Полный список системных перечислений можно узнать только в справочной системе вашей программы.

Форум поддержки читателей книги «Практическое пособие разработчика. Примеры и типовые приемы»

Как можно удалить из строки все пробелы, табы, переносы коретки и т.п., причем оставив между словами один пробел?

ВходящаяСтрока = «Аааа аааа ааааа ааа

ПолученнаяСтрока = «»Аааа аааа ааааа ааа ааааа ааааааааа ааа ааааа»

Не подскажите мне как можно удалить пробелы в справочнике Номенклатура в реквизите «код». дело в том что я экспортировал номенклатуры с excel и код стал отображаться с прбелом после тысячи «1 000» а надо «1000». Хотелось бы написать обработчик который бы проверил строку на пробелы и удалил их. Может кто подскажет?

Смотрите так же:  Сергей чернышев адвокат саратов

Может просто изменить формат числа в excel?

Да можно было так сделать заранее, но вся работа была проделана. Там куча групп, подгрупп и наименований товаров. Как бы делать все заново потребует много времени. Хотелось бы написать обработчик

Я же ранее в этой теме уже предложил работающую функцию:

Функция УдалениеНезначимыхСимволов (ВходящаяСтрока) Экспорт

Т.е мне стоит написать эту функцию на сервере, а потом к ней обратиться? Спасибо щас буду пробовать. А мой вариант не правилен?

Видимо что-то я делаю не так. Вот полный текст кода

Если ЭлементыФормы.ПолеСправочник.Значение = «Номенклатура» Тогда
Спр = Справочники.Номенклатура;
ИначеЕсли ЭлементыФормы.ПолеСправочник.Значение = «Контрагенты» Тогда
Спр = Справочники.Контрагенты;
Иначе Сообщить («Не выбран справочник!»);
КонецЕсли;

Выборка = Спр.Выбрать();
КолЗамен = 0;

Пока Выборка.Следующий() Цикл
НайденныйОбъект = Спр.НайтиПоКоду(Выборка.Код);
Если НайденныйОбъект = Спр.ПустаяСсылка() или Выборка.ЭтоГруппа Тогда
Сообщить(«Пустая ссылка или группа!»);
КонецЕсли;

ТекущийОбъект = НайденныйОбъект.ПолучитьОбъект();
Если ТекущийОбъект.Код Тогда
УдалениеНезначимыхСимволов (ВходящаяСтрока);
//ТекущийОбъект.Код = СтрЗаменить(ТекущийОбъект.Код,Символы.НПП,»»);
//ТекущийОбъект.Код = Формат(ТекущийОбъект.Код,»ЧГ=0″);
//ТекущийОбъект.Код = СокрЛП(Формат(ТекущийОбъект.Код,»ЧГ=0″));
Продолжить;
КолЗамен = КолЗамен+1;
КонецЕсли;
// ТекущийОбъект.Код =СтрЗаменить(ТекущийОбъект.Код,Символы.НПП,»»);
// ТекущийОбъект.Код = СокрЛП(Выборка.Наименование);
ТекущийОбъект.Записать();
КонецЦикла;
Сообщить(«Замена произведена на » + КолЗамен + » элементах.»);

&НаСервере
Функция УдалениеНезначимыхСимволов (ВходящаяСтрока) Экспорт

ВходящаяСтрока = СокрЛП(ВходящаяСтрока);
ДлинаСтроки = СтрДлина(ВходящаяСтрока);
КонечнаяСтрока = Строка(«»);

Пока ДлинаСтроки > 0 Цикл

ПервыйСимвол = Лев(ВходящаяСтрока, 1);

Если Не ПустаяСтрока(ПервыйСимвол) Тогда
КонечнаяСтрока = КонечнаяСтрока + ПервыйСимвол;
Отступ = 2;
ДлинаСтроки = ДлинаСтроки — 1;
Иначе
КонечнаяСтрока = КонечнаяСтрока + » «;
ВходящаяСтрока = СокрЛ(ВходящаяСтрока);
ДлинаСтроки = СтрДлина(ВходящаяСтрока);
Отступ = 1;
КонецЕсли;

Если ДлинаСтроки > 1 тогда
ВходящаяСтрока = Сред(ВходящаяСтрока, Отступ, ДлинаСтроки);
Иначе
КонечнаяСтрока = КонечнаяСтрока + Сред(ВходящаяСтрока, Отступ, 1);
ДлинаСтроки = 0;
КонецЕсли;

Обсуждение закрыто.